Console Output

Started by upstream project "Osmocom-repo-install-debian9" build number 196
originally caused by:
 Started by timer
Running as SYSTEM
Building remotely on build2-deb9build-ansible (ttcn3 osmocom-gerrit-debian9 osmocom-master-debian9 repo-install-test coverity) in workspace /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test
The recommended git tool is: NONE
No credentials specified
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository git://git.osmocom.org/osmo-ci
 > git init /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test # timeout=10
Fetching upstream changes from git://git.osmocom.org/osmo-ci
 > git --version # timeout=10
 > git --version # 'git version 2.11.0'
 > git fetch --tags --progress -- git://git.osmocom.org/osmo-ci +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url git://git.osmocom.org/osmo-ci # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
Avoid second fetch
Checking out Revision b70fede4523205ebcfd279d1a15a3c9f43470a8d (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f b70fede4523205ebcfd279d1a15a3c9f43470a8d # timeout=10
Commit message: "lint: ignore LONG_LINE"
 > git rev-list --no-walk b70fede4523205ebcfd279d1a15a3c9f43470a8d # timeout=10
[repo-install-test] $ /bin/sh -xe /tmp/jenkins8040688077162834257.sh
+ export OSMO_BRANCH_DOCKER_PLAYGROUND=master
+ export FEED=nightly
+ scripts/repo-install-test.sh debian9
+ dirname scripts/repo-install-test.sh
+ . scripts/common.sh
+ dirname scripts/repo-install-test.sh
+ realpath scripts/..
+ OSMO_CI_DIR=/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test
+ OSMO_GIT_URL=https://git.osmocom.org
+ OSMO_GIT_URL_GERRIT=https://gerrit.osmocom.org
+ OSMO_RELEASE_REPOS=
	libasn1c
	libosmo-abis
	libosmocore
	libosmo-netif
	libosmo-sccp
	libsmpp34
	libusrp
	osmo-bsc
	osmo-bts
	osmo-ggsn
	osmo-hlr
	osmo-iuh
	osmo-mgw
	osmo-msc
	osmo-pcu
	osmo-sgsn
	osmo-sip-connector
	osmo-sysmon
	osmo-trx
	osmocom-bb

+ OSMO_BRANCH_DOCKER_PLAYGROUND=master
+ DISTRO=debian9
+ DISTROS=
	centos8
	debian9
	debian10

+ check_usage
+ local i
+ [ debian9 = centos8 ]
+ [ debian9 = debian9 ]
+ return
+ docker_images_require debian9-repo-install-test
+ local oldpwd=/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test
+ [ -L _docker_playground ]
+ [ -d _docker_playground ]
+ git clone https://git.osmocom.org/docker-playground/ _docker_playground
Cloning into '_docker_playground'...
+ cd _docker_playground
+ git checkout master
Already on 'master'
Your branch is up-to-date with 'origin/master'.
+ git reset --hard origin/master
HEAD is now at d201460 debian-stretch-titan: Wait for interface to be _up_ not just its existance
+ cd debian9-repo-install-test
+ . ../jenkins-common.sh
+ realpath ../_cache
+ CACHE_DIR=/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/_cache
+ realpath ../scripts/kernel-test
+ KERNEL_TEST_DIR=/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/scripts/kernel-test
+ IMAGE_DIR_PREFIX=..
+ set -x
+ [ x = x ]
+ REPO_USER=osmocom-build
+ [ x/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test = x ]
+ VOL_BASE_DIR=/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/logs
+ rm -rf /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/logs
+ mkdir -p /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/logs
+ [ ! -d /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/logs ]
+ [ xjenkins-Osmocom-repo-install-debian9-feed=nightly,label=repo-install-test-196 = x ]
+ basename /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/debian9-repo-install-test
+ SUITE_NAME=debian9-repo-install-test
+ NET_NAME=debian9-repo-install-test
+ docker_images_require debian9-repo-install-test
+ local i
+ local from_line
+ local pull_arg
+ local upstream_distro_arg
+ local distro_arg
+ local depends
+ local dir
+ docker_depends debian9-repo-install-test
+ local feed
+ depends=
+ [ -n  ]
+ docker_distro_from_image_name debian9-repo-install-test
+ echo debian-stretch
+ distro_arg=debian-stretch
+ [ -z  ]
+ docker_upstream_distro_from_image_name debian9-repo-install-test
+ echo debian:stretch
+ upstream_distro_arg=debian:stretch
+ docker_dir_from_image_name debian9-repo-install-test
+ echo debian9-repo-install-test
+ dir=debian9-repo-install-test
+ pull_arg=--pull
+ grep ^FROM ../debian9-repo-install-test/Dockerfile
+ from_line=FROM	${REGISTRY}/${UPSTREAM_DISTRO}
+ echo FROM	${REGISTRY}/${UPSTREAM_DISTRO}
+ grep -q $USER
+ echo Building image: debian9-repo-install-test (export NO_DOCKER_IMAGE_BUILD=1 to prevent this)
Building image: debian9-repo-install-test (export NO_DOCKER_IMAGE_BUILD=1 to prevent this)
+ make -C ../debian9-repo-install-test PULL=--pull UPSTREAM_DISTRO=debian:stretch DISTRO=debian-stretch IMAGE=osmocom-build/debian9-repo-install-test
make: Entering directory '/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/debian9-repo-install-test'
awk: fatal: cannot open file `.release' for reading (No such file or directory)
awk: fatal: cannot open file `.release' for reading (No such file or directory)
awk: fatal: cannot open file `.release' for reading (No such file or directory)
rm -rf .common
cp -r /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/common .common
INFO: .release created
release=0.0.0
docker build \
	--build-arg USER=osmocom-build \
	--build-arg UID=1000 \
	--build-arg REGISTRY=docker.io \
	--build-arg OSMO_TTCN3_BRANCH=master \
	--build-arg UPSTREAM_DISTRO=debian:stretch \
	--build-arg DISTRO=debian-stretch \
	--build-arg OSMOCOM_REPO_MIRROR=http://download.opensuse.org \
	--build-arg OSMOCOM_REPO_PATH=repositories/network:/osmocom: \
	--build-arg OSMOCOM_REPO_VERSION=latest \
	--build-arg OSMOCOM_REPO_TESTSUITE_MIRROR=http://download.opensuse.org \
	--build-arg LIBOSMOCORE_BRANCH=master \
	--build-arg OSMO_BB_BRANCH=master \
	--build-arg OSMO_BSC_BRANCH=master \
	--build-arg OSMO_BTS_BRANCH=master \
	--build-arg OSMO_GBPROXY_BRANCH=master \
	--build-arg OSMO_GGSN_BRANCH=master \
	--build-arg OSMO_GSM_TESTER_BRANCH=master \
	--build-arg OSMO_HLR_BRANCH=master \
	--build-arg OSMO_IUH_BRANCH=master \
	--build-arg OSMO_MGW_BRANCH=master \
	--build-arg OSMO_MSC_BRANCH=master \
	--build-arg OSMO_NITB_BRANCH=master \
	--build-arg OSMO_PCU_BRANCH=master \
	--build-arg OSMO_SGSN_BRANCH=master \
	--build-arg OSMO_SIP_BRANCH=master \
	--build-arg OSMO_STP_BRANCH=master \
	--pull -t osmocom-build/debian9-repo-install-test:latest .
Sending build context to Docker daemon   7.68kB

Step 1/5 : ARG	USER
Step 2/5 : ARG	REGISTRY=docker.io
Step 3/5 : ARG	UPSTREAM_DISTRO=debian:stretch
Step 4/5 : FROM	${REGISTRY}/${UPSTREAM_DISTRO}
stretch: Pulling from library/debian
Digest: sha256:06f9296409de8cfecaff43aaee6d608ed48a95c0cac0da2a418ff526acedf67b
Status: Image is up to date for debian:stretch
 ---> 2c3ad12c6ecf
Step 5/5 : RUN	apt-get update && 	apt-get install -y --no-install-recommends 		aptitude 		gnupg 		systemd
 ---> Using cache
 ---> 5cb7495e5b5b
[Warning] One or more build-args [OSMO_GBPROXY_BRANCH OSMO_GGSN_BRANCH OSMO_SGSN_BRANCH OSMO_SIP_BRANCH OSMOCOM_REPO_TESTSUITE_MIRROR OSMO_BB_BRANCH OSMO_IUH_BRANCH OSMO_MSC_BRANCH OSMO_STP_BRANCH OSMO_TTCN3_BRANCH LIBOSMOCORE_BRANCH OSMOCOM_REPO_VERSION OSMO_BTS_BRANCH OSMO_GSM_TESTER_BRANCH OSMO_NITB_BRANCH OSMO_PCU_BRANCH OSMOCOM_REPO_PATH OSMO_BSC_BRANCH OSMO_HLR_BRANCH OSMO_MGW_BRANCH UID DISTRO OSMOCOM_REPO_MIRROR] were not consumed
Successfully built 5cb7495e5b5b
Successfully tagged osmocom-build/debian9-repo-install-test:latest
rm -rf .common
make: Leaving directory '/home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/_docker_playground/debian9-repo-install-test'
+ docker_image_exists debian9-repo-install-test
+ docker images -q osmocom-build/debian9-repo-install-test
+ test -n 5cb7495e5b5b
+ list_osmo_packages debian-stretch debian9-repo-install-test
+ local distro=debian-stretch
+ local image=debian9-repo-install-test
+ local docker_run_sh=docker run --rm --entrypoint=/bin/sh osmocom-build/debian9-repo-install-test -c
+ [ -n  ]
+ return
+ ret=0
+ cd /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test
+ return 0
+ FEED=nightly
+ PROJ=network:osmocom:nightly
+ CONTAINER=debian9-repo-install-test-nightly
+ [ -z  ]
+ TESTS=
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	
+ [ -z  ]
+ PROJ_CONFLICT=network:osmocom:latest
+ [ debian9 = centos8 ]
+ docker inspect -f {{.State.Running}} debian9-repo-install-test-nightly
+ [  = true ]
+ args=
+ [ -n  ]
+ check_if_systemd_is_running
+ docker run --rm -v /home/osmocom-build/jenkins/workspace/Osmocom-repo-install-debian9/feed/nightly/label/repo-install-test/scripts/repo-install-test:/repo-install-test:ro --name debian9-repo-install-test-nightly -e FEED=nightly -e PROJ=network:osmocom:nightly -e PROJ_CONFLICT=network:osmocom:latest -e DISTRO=debian9 -e TESTS=
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	 -e+  container=docker --tmpfs /run --tmpfs /run/lock --tmpfs /tmpseq -v 1 /sys/fs/cgroup:/sys/fs/cgroup:ro 10
 --cap-add SYS_ADMIN --cap-add SYS_NICE osmocom-build/debian9-repo-install-test /lib/systemd/systemd
+ sleep 1
+ docker exec debian9-repo-install-test-nightly systemctl status
● cafe24092d92
    State: running
     Jobs: 0 queued
   Failed: 0 units
    Since: Thu 2021-08-05 10:40:15 UTC; 301ms ago
   CGroup: /docker/cafe24092d92586b7c3753a0244ae6efc129df579cfd004d3a3d3eb029b7d70f
           ├─26 systemctl status
           ├─init.scope
           │ └─1 /lib/systemd/systemd
           └─system.slice
             └─systemd-journald.service
               └─19 /lib/systemd/systemd-journald
+ return
+ ret=0
+ docker exec debian9-repo-install-test-nightly /repo-install-test/run-inside-docker.sh
Checking feed: nightly
Checking project: network:osmocom:nightly
Checking conflicting project: network:osmocom:latest
Linux distribution: debian9
Enabled tests: 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	
+ SERVICES=
	osmo-bsc
	osmo-gbproxy
	osmo-gtphub
	osmo-hlr
	osmo-mgw
	osmo-msc
	osmo-pcap-client
	osmo-sip-connector
	osmo-stp

+ SERVICES_NIGHTLY=
	osmo-pcap-server
	osmo-sgsn
	osmo-pcu
	osmo-hnbgw
	osmo-bts-virtual

+ distro_obsdir
+ echo Debian_9.0
+ DISTRO_OBSDIR=Debian_9.0
+ check_env
+ [ -n nightly ]
+ echo Checking feed: nightly
+ [ -n network:osmocom:nightly ]
+ echo Checking project: network:osmocom:nightly
+ [ -n network:osmocom:latest ]
+ echo Checking conflicting project: network:osmocom:latest
+ [ -n debian9 ]
+ echo Linux distribution: debian9
+ [ -n 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	 ]
+ echo Enabled tests: 
		test_conflict
		install_repo_packages
		test_binaries
		services_check
	
+ configure_keep_cache
+ [ -z  ]
+ return
+ configure_osmocom_repo network:osmocom:nightly
+ configure_osmocom_repo_debian network:osmocom:nightly
+ local proj=network:osmocom:nightly
+ proj_with_slashes network:osmocom:nightly
+ echo network:osmocom:nightly
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:nightly_Release.key
+ echo Configuring Osmocom repository
+ [ -e /var/cache/apt/network:osmocom:nightly_Release.key ]
Configuring Osmocom repository
+ apt-get update
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [53.0 kB]
Ign:2 http://deb.debian.org/debian stretch InRelease
Get:3 http://deb.debian.org/debian stretch-updates InRelease [93.6 kB]
Hit:4 http://deb.debian.org/debian stretch Release
Get:5 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [707 kB]
Fetched 853 kB in 0s (2769 kB/s)
Reading package lists...
+ apt install -y wget

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  ca-certificates libffi6 libgmp10 libgnutls30 libhogweed4 libidn2-0
  libp11-kit0 libpsl5 libssl1.1 libtasn1-6 libunistring0 openssl publicsuffix
Suggested packages:
  gnutls-bin
The following NEW packages will be installed:
  ca-certificates libffi6 libgmp10 libgnutls30 libhogweed4 libidn2-0
  libp11-kit0 libpsl5 libssl1.1 libtasn1-6 libunistring0 openssl publicsuffix
  wget
0 upgraded, 14 newly installed, 0 to remove and 0 not upgraded.
Need to get 5034 kB of archives.
After this operation, 13.9 MB of additional disk space will be used.
Get:1 http://security.debian.org/debian-security stretch/updates/main amd64 libssl1.1 amd64 1.1.0l-1~deb9u3 [1359 kB]
Get:2 http://deb.debian.org/debian stretch/main amd64 libgmp10 amd64 2:6.1.2+dfsg-1 [253 kB]
Get:3 http://security.debian.org/debian-security stretch/updates/main amd64 libp11-kit0 amd64 0.23.3-2+deb9u1 [112 kB]
Get:4 http://deb.debian.org/debian stretch/main amd64 libhogweed4 amd64 3.3-1+b2 [136 kB]
Get:5 http://security.debian.org/debian-security stretch/updates/main amd64 openssl amd64 1.1.0l-1~deb9u3 [749 kB]
Get:6 http://deb.debian.org/debian stretch/main amd64 libffi6 amd64 3.2.1-6 [20.4 kB]
Get:7 http://deb.debian.org/debian stretch/main amd64 libtasn1-6 amd64 4.10-1.1+deb9u1 [50.6 kB]
Get:8 http://deb.debian.org/debian stretch/main amd64 libgnutls30 amd64 3.5.8-5+deb9u5 [896 kB]
Get:9 http://security.debian.org/debian-security stretch/updates/main amd64 ca-certificates all 20200601~deb9u2 [168 kB]
Get:10 http://deb.debian.org/debian stretch/main amd64 libunistring0 amd64 0.9.6+really0.9.3-0.1 [279 kB]
Get:11 http://deb.debian.org/debian stretch/main amd64 libidn2-0 amd64 0.16-1+deb9u1 [60.7 kB]
Get:12 http://deb.debian.org/debian stretch/main amd64 libpsl5 amd64 0.17.0-3 [41.8 kB]
Get:13 http://deb.debian.org/debian stretch/main amd64 wget amd64 1.18-5+deb9u3 [800 kB]
Get:14 http://deb.debian.org/debian stretch/main amd64 publicsuffix all 20190415.1030-0+deb9u1 [108 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 5034 kB in 0s (33.6 MB/s)
Selecting previously unselected package libssl1.1:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 7703 files and directories currently installed.)
Preparing to unpack .../00-libssl1.1_1.1.0l-1~deb9u3_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.0l-1~deb9u3) ...
Selecting previously unselected package libgmp10:amd64.
Preparing to unpack .../01-libgmp10_2%3a6.1.2+dfsg-1_amd64.deb ...
Unpacking libgmp10:amd64 (2:6.1.2+dfsg-1) ...
Selecting previously unselected package libhogweed4:amd64.
Preparing to unpack .../02-libhogweed4_3.3-1+b2_amd64.deb ...
Unpacking libhogweed4:amd64 (3.3-1+b2) ...
Selecting previously unselected package libffi6:amd64.
Preparing to unpack .../03-libffi6_3.2.1-6_amd64.deb ...
Unpacking libffi6:amd64 (3.2.1-6) ...
Selecting previously unselected package libp11-kit0:amd64.
Preparing to unpack .../04-libp11-kit0_0.23.3-2+deb9u1_amd64.deb ...
Unpacking libp11-kit0:amd64 (0.23.3-2+deb9u1) ...
Selecting previously unselected package libtasn1-6:amd64.
Preparing to unpack .../05-libtasn1-6_4.10-1.1+deb9u1_amd64.deb ...
Unpacking libtasn1-6:amd64 (4.10-1.1+deb9u1) ...
Selecting previously unselected package libgnutls30:amd64.
Preparing to unpack .../06-libgnutls30_3.5.8-5+deb9u5_amd64.deb ...
Unpacking libgnutls30:amd64 (3.5.8-5+deb9u5) ...
Selecting previously unselected package libunistring0:amd64.
Preparing to unpack .../07-libunistring0_0.9.6+really0.9.3-0.1_amd64.deb ...
Unpacking libunistring0:amd64 (0.9.6+really0.9.3-0.1) ...
Selecting previously unselected package libidn2-0:amd64.
Preparing to unpack .../08-libidn2-0_0.16-1+deb9u1_amd64.deb ...
Unpacking libidn2-0:amd64 (0.16-1+deb9u1) ...
Selecting previously unselected package libpsl5:amd64.
Preparing to unpack .../09-libpsl5_0.17.0-3_amd64.deb ...
Unpacking libpsl5:amd64 (0.17.0-3) ...
Selecting previously unselected package wget.
Preparing to unpack .../10-wget_1.18-5+deb9u3_amd64.deb ...
Unpacking wget (1.18-5+deb9u3) ...
Selecting previously unselected package openssl.
Preparing to unpack .../11-openssl_1.1.0l-1~deb9u3_amd64.deb ...
Unpacking openssl (1.1.0l-1~deb9u3) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../12-ca-certificates_20200601~deb9u2_all.deb ...
Unpacking ca-certificates (20200601~deb9u2) ...
Selecting previously unselected package publicsuffix.
Preparing to unpack .../13-publicsuffix_20190415.1030-0+deb9u1_all.deb ...
Unpacking publicsuffix (20190415.1030-0+deb9u1) ...
Setting up libtasn1-6:amd64 (4.10-1.1+deb9u1) ...
Setting up libgmp10:amd64 (2:6.1.2+dfsg-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up publicsuffix (20190415.1030-0+deb9u1) ...
Setting up libunistring0:amd64 (0.9.6+really0.9.3-0.1) ...
Setting up libssl1.1:amd64 (1.1.0l-1~deb9u3) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Setting up openssl (1.1.0l-1~deb9u3) ...
Setting up libffi6:amd64 (3.2.1-6) ...
Setting up ca-certificates (20200601~deb9u2) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (you may need to install the Term::ReadLine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Updating certificates in /etc/ssl/certs...
137 added, 0 removed; done.
Setting up libidn2-0:amd64 (0.16-1+deb9u1) ...
Setting up libpsl5:amd64 (0.17.0-3) ...
Setting up libhogweed4:amd64 (3.3-1+b2) ...
Setting up libp11-kit0:amd64 (0.23.3-2+deb9u1) ...
Setting up libgnutls30:amd64 (3.5.8-5+deb9u5) ...
Setting up wget (1.18-5+deb9u3) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for ca-certificates (20200601~deb9u2) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
+ wget -O /var/cache/apt/network:osmocom:nightly_Release.key https://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0//Release.key
--2021-08-05 10:40:22--  https://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0//Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1080 (1.1K)
Saving to: '/var/cache/apt/network:osmocom:nightly_Release.key'

     0K .                                                     100% 33.2M=0s

2021-08-05 10:40:22 (33.2 MB/s) - '/var/cache/apt/network:osmocom:nightly_Release.key' saved [1080/1080]

+ apt-key add /var/cache/apt/network:osmocom:nightly_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/ ./
+ apt-get update
Get:1 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ InRelease [1590 B]
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://security.debian.org/debian-security stretch/updates InRelease
Hit:4 http://deb.debian.org/debian stretch-updates InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Get:6 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ Packages [93.1 kB]
Fetched 94.7 kB in 0s (256 kB/s)
Reading package lists...

### Running test: test_conflict ###

+ set +x
+ test_conflict
+ test_conflict_debian
+ apt-get -y install libosmocore
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  libosmocodec0 libosmocoding0 libosmocore17 libosmoctrl0 libosmogb12
  libosmogsm16 libosmosim2 libosmousb0 libosmovty9 libpcsclite1 libsctp1
  libtalloc2 libusb-1.0-0 osmocom-nightly
Suggested packages:
  pcscd lksctp-tools
The following NEW packages will be installed:
  libosmocodec0 libosmocoding0 libosmocore libosmocore17 libosmoctrl0
  libosmogb12 libosmogsm16 libosmosim2 libosmousb0 libosmovty9 libpcsclite1
  libsctp1 libtalloc2 libusb-1.0-0 osmocom-nightly
0 upgraded, 15 newly installed, 0 to remove and 0 not upgraded.
Need to get 1029 kB of archives.
After this operation, 2489 kB of additional disk space will be used.
Get:1 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ osmocom-nightly 1.0.0.202108050026 [1114 B]
Get:2 http://deb.debian.org/debian stretch/main amd64 libsctp1 amd64 1.0.17+dfsg-1+b1 [28.1 kB]
Get:3 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmocore17 1.5.1.188.7af86.202108050026 [119 kB]
Get:4 http://deb.debian.org/debian stretch/main amd64 libtalloc2 amd64 2.1.8-1 [36.3 kB]
Get:5 http://deb.debian.org/debian stretch/main amd64 libpcsclite1 amd64 1.8.20-1 [56.5 kB]
Get:6 http://deb.debian.org/debian stretch/main amd64 libusb-1.0-0 amd64 2:1.0.21-1 [53.9 kB]
Get:7 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmocodec0 1.5.1.188.7af86.202108050026 [43.4 kB]
Get:8 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmogsm16 1.5.1.188.7af86.202108050026 [199 kB]
Get:9 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmocoding0 1.5.1.188.7af86.202108050026 [59.6 kB]
Get:10 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmovty9 1.5.1.188.7af86.202108050026 [93.7 kB]
Get:11 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmogb12 1.5.1.188.7af86.202108050026 [149 kB]
Get:12 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmoctrl0 1.5.1.188.7af86.202108050026 [51.2 kB]
Get:13 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmosim2 1.5.1.188.7af86.202108050026 [57.2 kB]
Get:14 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmousb0 1.5.1.188.7af86.202108050026 [43.5 kB]
Get:15 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ libosmocore 1.5.1.188.7af86.202108050026 [37.5 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 1029 kB in 0s (12.7 MB/s)
Selecting previously unselected package osmocom-nightly.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 8167 files and directories currently installed.)
Preparing to unpack .../00-osmocom-nightly_1.0.0.202108050026_amd64.deb ...
Unpacking osmocom-nightly (1.0.0.202108050026) ...
Selecting previously unselected package libsctp1:amd64.
Preparing to unpack .../01-libsctp1_1.0.17+dfsg-1+b1_amd64.deb ...
Unpacking libsctp1:amd64 (1.0.17+dfsg-1+b1) ...
Selecting previously unselected package libtalloc2:amd64.
Preparing to unpack .../02-libtalloc2_2.1.8-1_amd64.deb ...
Unpacking libtalloc2:amd64 (2.1.8-1) ...
Selecting previously unselected package libosmocore17:amd64.
Preparing to unpack .../03-libosmocore17_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmocore17:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmocodec0:amd64.
Preparing to unpack .../04-libosmocodec0_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmocodec0:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmogsm16:amd64.
Preparing to unpack .../05-libosmogsm16_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmogsm16:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmocoding0:amd64.
Preparing to unpack .../06-libosmocoding0_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmocoding0:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmovty9:amd64.
Preparing to unpack .../07-libosmovty9_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmovty9:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmogb12:amd64.
Preparing to unpack .../08-libosmogb12_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmogb12:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmoctrl0:amd64.
Preparing to unpack .../09-libosmoctrl0_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmoctrl0:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libpcsclite1:amd64.
Preparing to unpack .../10-libpcsclite1_1.8.20-1_amd64.deb ...
Unpacking libpcsclite1:amd64 (1.8.20-1) ...
Selecting previously unselected package libosmosim2:amd64.
Preparing to unpack .../11-libosmosim2_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmosim2:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libusb-1.0-0:amd64.
Preparing to unpack .../12-libusb-1.0-0_2%3a1.0.21-1_amd64.deb ...
Unpacking libusb-1.0-0:amd64 (2:1.0.21-1) ...
Selecting previously unselected package libosmousb0:amd64.
Preparing to unpack .../13-libosmousb0_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmousb0:amd64 (1.5.1.188.7af86.202108050026) ...
Selecting previously unselected package libosmocore.
Preparing to unpack .../14-libosmocore_1.5.1.188.7af86.202108050026_amd64.deb ...
Unpacking libosmocore (1.5.1.188.7af86.202108050026) ...
Setting up libsctp1:amd64 (1.0.17+dfsg-1+b1) ...
Setting up libpcsclite1:amd64 (1.8.20-1) ...
Setting up osmocom-nightly (1.0.0.202108050026) ...
Setting up libusb-1.0-0:amd64 (2:1.0.21-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up libtalloc2:amd64 (2.1.8-1) ...
Setting up libosmocore17:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmocodec0:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmovty9:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmogsm16:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmoctrl0:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmosim2:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmocoding0:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmousb0:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmogb12:amd64 (1.5.1.188.7af86.202108050026) ...
Setting up libosmocore (1.5.1.188.7af86.202108050026) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
+ configure_osmocom_repo_debian_remove network:osmocom:nightly
+ local proj=network:osmocom:nightly
+ rm /etc/apt/sources.list.d/network:osmocom:nightly.list
+ configure_osmocom_repo_debian network:osmocom:latest
+ local proj=network:osmocom:latest
+ proj_with_slashes network:osmocom:latest
+ echo network:osmocom:latest
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:latest_Release.key
+ echo Configuring Osmocom repository
+ [ -eConfiguring Osmocom repository
 /var/cache/apt/network:osmocom:latest_Release.key ]
+ apt-get update
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://deb.debian.org/debian stretch Release
Reading package lists...
+ apt install -y wget

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
wget is already the newest version (1.18-5+deb9u3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
+ wget -O /var/cache/apt/network:osmocom:latest_Release.key https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
--2021-08-05 10:40:28--  https://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0//Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1080 (1.1K)
Saving to: '/var/cache/apt/network:osmocom:latest_Release.key'

     0K .                                                     100% 32.9M=0s

2021-08-05 10:40:28 (32.9 MB/s) - '/var/cache/apt/network:osmocom:latest_Release.key' saved [1080/1080]

+ apt-key add /var/cache/apt/network:osmocom:latest_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0/ ./
+ apt-get update
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://deb.debian.org/debian stretch InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Get:4 http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0 ./ InRelease [1611 B]
Hit:5 http://deb.debian.org/debian stretch Release
Get:6 http://download.opensuse.org/repositories/network:/osmocom:/latest/Debian_9.0 ./ Packages [102 kB]
Fetched 103 kB in 0s (276 kB/s)
Reading package lists...
+ apt-get -y install osmo-mgw
+ tee /tmp/out
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 osmo-mgw : Depends: osmocom-latest but it is not going to be installed
            Depends: libosmoabis10 but it is not going to be installed
            Depends: libosmonetif8 but it is not going to be installed
            Depends: libosmotrau2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
+ [ -e /tmp/fail ]
+ find_patterns_or_exit /tmp/out requested an impossible situation ^The following packages have unmet dependencies: Depends: osmocom- but it is not going to be installed
+ local file=/tmp/out
+ local pattern
+ shift
+ grep -q requested an impossible situation /tmp/out
+ continue
+ grep -q ^The following packages have unmet dependencies: /tmp/out
+ continue
+ grep -q Depends: osmocom- /tmp/out
+ continue
+ grep -q but it is not going to be installed /tmp/out
+ continue
+ configure_osmocom_repo_debian_remove network:osmocom:latest
+ local proj=network:osmocom:latest
+ rm /etc/apt/sources.list.d/network:osmocom:latest.list
+ configure_osmocom_repo_debian network:osmocom:nightly
+ local proj=network:osmocom:nightly
+ proj_with_slashes network:osmocom:nightly
+ echo network:osmocom:nightly
+ sed s.:.:/.g
+ local obs_repo=download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/
+ local release_key=/var/cache/apt/network:osmocom:nightly_Release.key
+ echo Configuring Osmocom repository
Configuring Osmocom repository
+ [ -e /var/cache/apt/network:osmocom:nightly_Release.key ]
+ apt-key add /var/cache/apt/network:osmocom:nightly_Release.key
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
+ echo deb http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0/ ./
+ apt-get update
Get:1 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ InRelease [1590 B]
Hit:2 http://security.debian.org/debian-security stretch/updates InRelease
Ign:3 http://deb.debian.org/debian stretch InRelease
Hit:4 http://deb.debian.org/debian stretch-updates InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Get:7 http://download.opensuse.org/repositories/network:/osmocom:/nightly/Debian_9.0 ./ Packages [93.1 kB]
Fetched 94.7 kB in 0s (236 kB/s)
Reading package lists...
+ set +x
+ set +x
+ install_repo_packages
+ install_repo_packages_debian
+ local
### Test successful: test_conflict ###


### Running test: install_repo_packages ###

 obs=obs://build.opensuse.org/network:osmocom:nightly/Debian_9.0
+ echo Installing all repository packages
Installing all repository packages
+ aptitude search -F%p ?origin(obs://build.opensuse.org/network:osmocom:nightly/Debian_9.0) ?architecture(native)
+ sort
+ filter_packages_txt
+ grep -v ^# /repo-install-test/blacklist_debian9.txt
+ sort -u
+ comm -23 osmocom_packages_all.txt blacklist.txt
+ cat osmocom_packages.txt
+ apt install -y abisip-find binutils-arm-osmo-eabi binutils-arm-osmo-eabi-dbgsym libasn1c-dbg libasn1c-dev libasn1c1 libgtp-dbg libgtp-dev libgtp6 libgtpnl-dbg libgtpnl-dev libgtpnl-tools libgtpnl0 libifd-osmo-remsim-client0 libifd-osmo-remsim-client0-dbgsym liblimesuite-dev liblimesuite20.10-1 liblimesuite20.10-1-dbgsym liborcania-dev liborcania1.2 liborcania1.2-dbgsym libosmo-abis libosmo-abis-dbg libosmo-abis-dev libosmo-e1d-dev libosmo-e1d1 libosmo-e1d1-dbgsym libosmo-fl2k-dev libosmo-fl2k0 libosmo-fl2k0-dbgsym libosmo-gsup-client-dev libosmo-gsup-client0 libosmo-mgcp-client-dev libosmo-mgcp-client8 libosmo-mgcp-client8-dbgsym libosmo-mslookup-dev libosmo-mslookup0 libosmo-netif-dbg libosmo-netif-dev libosmo-netif-doc libosmo-ranap-dbg libosmo-ranap-dev libosmo-ranap3 libosmo-rspro-dev libosmo-rspro1 libosmo-rspro1-dbgsym libosmo-sabp-dbg libosmo-sabp-dev libosmo-sabp0 libosmo-sccp-dev libosmo-sigtran-dbg libosmo-sigtran-dev libosmo-sigtran-doc libosmo-sigtran5 libosmo-simtrace2-0 libosmo-simtrace2-0-dbgsym libosmo-simtrace2-dev libosmoabis10 libosmocodec-doc libosmocodec0 libosmocoding-doc libosmocoding0 libosmocore libosmocore-dbg libosmocore-dev libosmocore-doc libosmocore-utils libosmocore17 libosmoctrl-doc libosmoctrl0 libosmodsp-dbg libosmodsp-dev libosmodsp-doc libosmodsp0 libosmogb-doc libosmogb12 libosmogsm-doc libosmogsm16 libosmonetif8 libosmosim2 libosmotrau2 libosmousb0 libosmovty-doc libosmovty9 librtlsdr-dev librtlsdr0 librtlsdr0-dbgsym libsmpp1 libsmpp34-dbg libsmpp34-dev libsmpp34-utils libulfius-dev libulfius2.5 libulfius2.5-dbgsym libusrp-dev libusrp-doc libusrp-firmware libusrp-utils libusrp-utils-dbgsym libusrp1 libusrp1-dbgsym libyder-dev libyder2.0 libyder2.0-dbgsym limesuite limesuite-dbgsym limesuite-images limesuite-images20.10 limesuite-udev neocon neocon-dbgsym osmo-bsc osmo-bsc-bs11-utils osmo-bsc-dbg osmo-bsc-doc osmo-bsc-ipaccess-utils osmo-bsc-meas-utils osmo-bts-doc osmo-bts-trx osmo-bts-trx-dbg osmo-bts-virtual osmo-bts-virtual-dbg osmo-cbc osmo-cbc-dbg osmo-cbc-doc osmo-cbc-utils osmo-e1d osmo-e1d-dbgsym osmo-fl2k osmo-fl2k-dbgsym osmo-gbproxy osmo-gbproxy-dbg osmo-gbproxy-doc osmo-ggsn osmo-ggsn-dbg osmo-ggsn-doc osmo-gsm-manuals-dev osmo-gtphub osmo-gtphub-dbg osmo-hlr osmo-hlr-dbg osmo-hlr-doc osmo-hnbgw osmo-hnbgw-dbg osmo-hnbgw-doc osmo-mgw osmo-mgw-dbgsym osmo-mgw-doc osmo-msc osmo-msc-dbg osmo-msc-doc osmo-pcap-client osmo-pcap-client-dbg osmo-pcap-server osmo-pcap-server-dbg osmo-pcu osmo-pcu-dbg osmo-pcu-doc osmo-remsim-bankd osmo-remsim-bankd-dbgsym osmo-remsim-client-shell osmo-remsim-client-shell-dbgsym osmo-remsim-client-st2 osmo-remsim-client-st2-dbgsym osmo-remsim-doc osmo-remsim-server osmo-remsim-server-dbgsym osmo-sgsn osmo-sgsn-dbg osmo-sgsn-doc osmo-sip-connector osmo-sip-connector-dbg osmo-sip-connector-doc osmo-smlc osmo-smlc-dbg osmo-smlc-doc osmo-stp osmo-stp-dbg osmo-stp-doc osmo-sysmon osmo-sysmon-dbg osmo-trx osmo-trx-dbg osmo-trx-doc osmo-trx-ipc osmo-trx-lms osmo-trx-uhd osmo-trx-usrp1 osmo-uecups osmo-uecups-dbgsym osmocom-nightly python3-osmopy-libs python3-osmopy-utils rtl-sdr rtl-sdr-dbgsym simtrace2-firmware simtrace2-utils simtrace2-utils-dbgsym

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
libosmocodec0 is already the newest version (1.5.1.188.7af86.202108050026).
libosmocodec0 set to manually installed.
libosmocoding0 is already the newest version (1.5.1.188.7af86.202108050026).
libosmocoding0 set to manually installed.
libosmocore is already the newest version (1.5.1.188.7af86.202108050026).
libosmocore17 is already the newest version (1.5.1.188.7af86.202108050026).
libosmocore17 set to manually installed.
libosmoctrl0 is already the newest version (1.5.1.188.7af86.202108050026).
libosmoctrl0 set to manually installed.
libosmogb12 is already the newest version (1.5.1.188.7af86.202108050026).
libosmogb12 set to manually installed.
libosmogsm16 is already the newest version (1.5.1.188.7af86.202108050026).
libosmogsm16 set to manually installed.
libosmosim2 is already the newest version (1.5.1.188.7af86.202108050026).
libosmosim2 set to manually installed.
libosmousb0 is already the newest version (1.5.1.188.7af86.202108050026).
libosmousb0 set to manually installed.
libosmovty9 is already the newest version (1.5.1.188.7af86.202108050026).
libosmovty9 set to manually installed.
osmocom-nightly is already the newest version (1.0.0.202108050026).
osmocom-nightly set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 osmo-cbc : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-cbc-dbg : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-cbc-doc : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-cbc-utils : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-gbproxy : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-gbproxy-dbg : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
 osmo-gbproxy-doc : Depends: osmocom-nightly (= 1.0.0.202108040026) but 1.0.0.202108050026 is to be installed
E: Unable to correct problems, you have held broken packages.
+ ret=1
+ [ -n  ]
+ docker container kill debian9-repo-install-test-nightly
debian9-repo-install-test-nightly
+ exit 1
Build step 'Execute shell' marked build as failure
Sending e-mails to: jenkins-notifications@lists.osmocom.org
Finished: FAILURE