osmo-cbc (0.5.1) unstable; urgency=medium

  [ Oliver Smith ]
  * contrib/jenkins: libosmo-abis after libosmo-netif

  [ Pau Espin Pedrol ]
  * .gitignore: Add *~
  * cbsp_link: Log unexpected return error codes
  * abis: Fix reusing link->conn while it is being destroyed
  * jenkins.sh: Skip building unneeded libosmo-abis

 -- Oliver Smith <osmith@sysmocom.de>  Wed, 12 Feb 2025 14:30:50 +0100

osmo-cbc (0.5.0) unstable; urgency=medium

  [ Harald Welte ]
  * cbc-apitool: Make character set configurable

  [ Andreas Eversberg ]
  * Use uniform log format for default config files

  [ Vadim Yanitskiy ]
  * build: include debian/ into the release tarball
  * README.md: cosmetic: fix a typo

  [ Pau Espin Pedrol ]
  * SBcAP: Update as1nc skeleton and generated code

  [ Max ]
  * .deb/.rpm: add osmocom user during package install

  [ Oliver Smith ]
  * .deb/.rpm: various fixes related to non-root
  * contrib: remove rpm spec file
  * debian/postinst: add checks, be verbose

 -- Oliver Smith <osmith@sysmocom.de>  Thu, 25 Jul 2024 09:46:02 +0200

osmo-cbc (0.4.2) unstable; urgency=medium

  [ Vadim Yanitskiy ]
  * {src,tests/sbcap}/Makefile.am: reorder libraries in LDADD
  * tests: use -no-install libtool flag to avoid ./lt-* scripts

  [ Oliver Smith ]
  * debian: set compat level to 10
  * systemd: depend on networking-online.target

  [ Pau Espin Pedrol ]
  * sbcap: Update asn1c skeleton files
  * README.md: Document generation of SBcAP code from ASN.1 files
  * Catch and forbid configuring peers before configuring main protocol node

 -- Pau Espin Pedrol <pespin@sysmocom.de>  Tue, 12 Sep 2023 17:08:37 +0200

osmo-cbc (0.4.1) unstable; urgency=medium

  [ Vadim Yanitskiy ]
  * contrib/jenkins.sh: also execute maintainer-clean target
  * contrib/jenkins.sh: execute 'distcheck' with $PARALLEL_MAKE
  * contrib/jenkins.sh: fix 'publish' target

  [ Max ]
  * Set working directory in systemd service file

  [ arehbein ]
  * osmo-cbc: Transition to use of 'telnet_init_default'

 -- Pau Espin Pedrol <pespin@sysmocom.de>  Tue, 07 Feb 2023 17:39:54 +0100

osmo-cbc (0.4.0) unstable; urgency=medium

  [ Pau Espin Pedrol ]
  * Configure libosmocore logging system as multithread
  * Move peer to DELETED state before signalling parent FSM with DELETE_(N)ACK
  * Fix typos in error messages
  * main: remove newline char in perror() call
  * cbsp_server: Exit process gracefully if binding socket fails
  * Move header files to include/osmocom/cbc/ dir
  * Improve error handling when forwarding ECBE msg to CBSP
  * cbsp: Clean up conn closed paths
  * rest_api: Fix cbs.data_user_len not set in 'payload_encoded'
  * Add sbcap library
  * Add unit tests for sbcap
  * sbcap: Update asn1c skeleton files
  * Add initial SBc-AP support to osmo-cbc
  * doc: user manual: fix typo
  * doc: Document SBc-AP support and config
  * Fix printf format in 32bit arch
  * vty: Fix call to OSMO_STRBUF_PRINTF
  * sbcap: Update asn1c skeleton files
  * Improve example osmo-cbc.cfg file
  * sbcap_server.c: Remove unneeded goto
  * sbcap_server: Log all sctp notif
  * sbcap_server: Fix double-free of rx msg if conn is destroyed
  * Split cbc_peer to its own .c and .h files
  * cbc_peer: Close SBcAP conn when removing active peer
  * Move function defined in rest_it_op.c to rest_it_op.h
  * Move vty stuff to its own header cbc_vty.h
  * Split cbc_message related code to its own .c and .h file
  * Get rid of internal.h
  * sbcap_server.h: Remove unused fields
  * cbsp_server.c: Drop unused code
  * Rename CBSP,SABP,SBcAP structs and APIs
  * Rename {cbsp,sbcap}_server(_fsm).h s/server/link/
  * Rename fields in cbc_{cbsp,sbcap}_mgr
  * Use cbc_{cbsp,sbcap}_link_close when possible
  * cbc_vty: Use value_string to define proto names used in vty
  * cbc_vty: print correct protocol when writing config
  * Refactor {cbsp,sbcap}_cbc_accept_cb
  * cbc_vty: write peer config nodes at the end
  * Make cbsp,sbcap mgr available in data model
  * Fix cbc_vty_go_parent() not being called
  * cbc_main: Fix setting default SBc-AP local address
  * vty: Define peer proto during 'peer' node cmd
  * Move struct cbc bring up code to its own file and functions
  * Split cbsp/sbcap server socket creation from struct allocation
  * cbc-apitool: Fix port stored in var as a string
  * cbc-apitool: print usage instead of crashing if no subcmd passed
  * sbcap: Fix encoding of Warning-Type
  * cosmetic: smscb_message_fsm.c: Fix typo in comment
  * Support CBSP/TCP and SBc-AP/SCTP client mode
  * cbc_vty: Fix missing indent char in dump_one_etws_msg
  * vty: Fix 'show message' not finding expired messages
  * vty: Add command to delete expired messages
  * vty: Print created and expired times for each message
  * sbcap_msg: Improve spec references for used IEs
  * vty: Fix typo in vty output
  * Rearrange cbc_message and cbsp message code
  * Rename functions generating CBSP/SBc-AP Write-Replace request
  * sbcap: Fix typo in sbcap_cause_vals
  * sbcap: Send Error Indication if decoding rx msg fails
  * sbcap: Drop unused events
  * sbcap: Improve logging of rx Error Indication
  * sbcap: Improve logging on non-implemented PWS Restart/Failure Ind
  * sbcap: Tx Error ind if Rx ProcedureCode is unknown
  * Move sbcap_as_find_ie() to libsbcap
  * sbcap: Fix typo in comment
  * sbcap: Log info about messages received and trasmitted
  * Move cbc_cell_id2str() and make it public
  * Move ASN1C enc/dec logging to its own category
  * sbcap: Request and handle Write Replace Warning Indication
  * sbcap: Store reported failed TAIs from WriteReplaceResponse in cbc_message_peer
  * sbcap: Improve handling of WriteReplaceWarnResponse
  * Introduce logging category smscb
  * Split event list for smscb_message_fsm and smscb_peer_fsm
  * Split smscb_peer_fsm into CBSP and SBcAP specific FSMs
  * cbc_main: Enable logging of fsm timeouts
  * Propagate error to caller when tx cbsp/sbcap Write-Replace-Req fails
  * sbcap: Fix NULL pointer dereference
  * cbsp/sbcap: Fix memleak in error condition (tx without link)
  * *_smscb_peer_fsm: Immediately NACK if Tx of msg failed
  * cbsp: Fix heap-use-after-free closing cli conn in connecting state
  * cbsp/sbcap: Set link fsm id with peer's name
  * cbsp/sbcap: Fail if trying to Tx on non-connected (connecting) link
  * sbcap: Add Concurrent-Warning-Message-Indicator IE to Write-Replace-Req
  * cbsp: Log storing of CellId info received from peers
  * cbsp: Store content of received Cell Id from Failed List

  [ Oliver Smith ]
  * gitreview: add new file
  * checkpatch.conf: ignore sbcap generated files
  * contrib/osmo-cbc.spec: add libosmo-sbcap0/-dev
  * debian: add subpackages libosmo-sbcap0/-dev
  * libosmo-sbcap.pc.in: new file

  [ Vadim Yanitskiy ]
  * tests/sbcap: fix wrong operator used in OSMO_ASSERT statement
  * cbc_vty: use install_element[_ve](), not install_lib_element[_ve]()
  * libosmo-sbcap: add -no-undefined to libosmo_sbcap_la_LDFLAGS

 -- Pau Espin Pedrol <pespin@sysmocom.de>  Mon, 08 Aug 2022 11:42:56 +0200

osmo-cbc (0.3.0) unstable; urgency=medium

  [ Vadim Yanitskiy ]
  * doc/examples: make osmo-cbc.cfg file more informative
  * VTY: cosmetic: use VTY_IPV46_CMD in the command string
  * VTY: fix incomplete 'remote-ip' command description

  [ Harald Welte ]
  * CBSP: Set Channel Indication IE in KILL for CBS
  * CBSP: Append/store results in KILL COMPLETE + KILL FAIL
  * cbc: Don't crash if peer->remote_host is NULL
  * update git URLs (git -> https; gitea)

  [ Pau Espin Pedrol ]
  * vty. Fix several typos and missing param descriptions
  * src/Makefile: Reformat files one per line
  * cbsp_server.h: Move function to the proper section
  * Rework cbsp_cbc_create() params
  * cbsp_server: Reorder logged message
  * .gitignore: add configure~

 -- Pau Espin Pedrol <pespin@sysmocom.de>  Wed, 29 Jun 2022 12:00:03 +0200

osmo-cbc (0.2.3) unstable; urgency=medium

  [ Harald Welte ]
  * varaible for atoi() result shouild be signed integer

 -- Pau Espin Pedrol <pespin@sysmocom.de>  Tue, 16 Nov 2021 18:05:21 +0100

osmo-cbc (0.2.2) unstable; urgency=medium

  * rest_api.c: Add missing \n in log line after error message
  * bring JSON schema in sync with reality
  * fix encoding of CBSP cell identifiers
  * Update dependencies to current libosmocore & co

 -- Harald Welte <laforge@osmocom.org>  Tue, 23 Feb 2021 20:40:44 +0100

osmo-cbc (0.2.1) unstable; urgency=medium

  [ Harald Welte ]
  * VTY: don't save dynamically-allocated "unknown" peers
  * cbc-apitool: compatibility with python < 3.7

  [ Oliver Smith ]
  * configure.ac: set -std=gnu11

 -- Harald Welte <laforge@osmocom.org>  Tue, 16 Feb 2021 22:39:23 +0100

osmo-cbc (0.2.0) unstable; urgency=medium

  [ Harald Welte ]
  * Initial release.
  * add link to upstream bug related to custom malloc/free
  * Add simplistic cbc-apitool.py as example on how to use the REST API
  * Add RPM spec file
  * Add README.md file
  * debian/osmo-cbc.install: Fix typo (extra apostrophe at EOL)
  * charset: Fix padding of USSD messages in 7bit GSM alphabet
  * spec file: Add missing libulfius dependency
  * cbc-apitool.py: Generalize, make parameters configurable
  * osmo-cbc.spec: Don't depend on libosmo-mgcp-client
  * osmo-cbc.spec: No AUTHORS file; correct name of README.md
  * manual: Chapters on configuration + vty introspection
  * vty: Allow IPv6 address for peer remote-ip
  * Make CBSP local bind IP+port VTY-configurable
  * Make ECBE (REST interface) local bind IP + port VTY-configurable
  * terminate if CBSP or ECBE ports cannot be bound
  * cbc-apitool: Fix parsing if no argument is goven
  * Makefile.am: cosmetic changes
  * Makefile.am: add *.json to EXTRA_DIST
  * manual: Document ECBE; include JSON schema; cross-references
  * manual: Add dotty graph on position of CBC in network
  * manual: Document cbc-apitool.py
  * debian: Package cbc-apitool.py as a sub-package
  * contrib/osmo-cbc.spec: Add sub-package osmo-cbc-utils
  * osmo-cbc.spec: License is AGPLv3-or-later + MIT

  [ Oliver Smith ]
  * contrib/jenkins: don't build osmo-gsm-manuals

 -- Harald Welte <laforge@osmocom.org>  Sun, 24 Jan 2021 16:15:49 +0100