#!/usr/bin/make -f
%:
	dh $@ --with autoreconf

CONFIGURE_FLAGS += \
	--enable-manuals \
	--enable-meas-vis \
	--with-systemdsystemunitdir=/lib/systemd/system \
	$(NULL)

override_dh_auto_configure:
	dh_auto_configure -- $(CONFIGURE_FLAGS)

# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
	dh_strip -posmo-bsc --dbg-package=osmo-bsc-dbg

# Print test results in case of a failure
override_dh_auto_test:
	dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)

# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
override_dh_compress:
	dh_compress -X.pdf